Lumion Support Center

Support for unlicensed users => Post here if you can't find your License Key => Topic started by: Nicholin on November 26, 2012, 04:27:47 pm

Title: Deleted materials
Post by: Nicholin on November 26, 2012, 04:27:47 pm
Hi everybody. I have the problem that I was changing a material from my object and dissapeared all materials I've applied before, around 30 materials. Now my scene has just the materials originaly from Revit model. How can I recover Lumion materials I've applied??? Thanks
Title: Re: Deleted materials
Post by: Zdenek Fajfrlik on November 26, 2012, 05:08:36 pm
did you maybe change all materials in your external 3d model and reloaded in lumion?

try to reload the old dae to check if the definitions are still valid in lumion....

regards stan
Title: Re: Deleted materials
Post by: Nicholin on November 27, 2012, 09:55:18 pm
No, i was working with only one dae file. I really dont know why Lumion number the different changes if we can't access to a backup, as we can see in Revit or Autocad, we can't work with previous files. I saved about 32 times and didn't have problems before.
Title: Re: Deleted materials
Post by: Zdenek Fajfrlik on November 27, 2012, 10:23:46 pm
No, i was working with only one dae file. I really dont know why Lumion number the different changes if we can't access to a backup, as we can see in Revit or Autocad, we can't work with previous files. I saved about 32 times and didn't have problems before.

did you overwrite the original dae or did you load a new one?
Title: Re: Deleted materials
Post by: Nicholin on November 27, 2012, 11:43:37 pm
Yes, I overwrote the original
Title: Re: Deleted materials
Post by: Zdenek Fajfrlik on November 28, 2012, 01:20:02 am
Yes, I overwrote the original

so you worked in the same file , exported to collada and reloaded in lumion

did you change the names of colours in your modeller? NOJT the colour itself, but the name ?
Title: Re: Deleted materials
Post by: Nicholin on November 28, 2012, 01:32:11 am
Yes, I work in the same Revit, dae and lumion file. As you say, I changed the name of a material in Revit, because i have the same material applied on objects with different coordinates, so i had to rename them in Revit, red stone 1, red stone 2, etc, so then in Lumion i adjust UVW by objects. But i did it few times, also reloaded the revit file for modeling changes . But i can't understand why all my Lumion materials  disapeared!!!
Title: Re: Deleted materials
Post by: BMcIsaac on November 28, 2012, 02:28:45 am
Did you have any duplicate names, one with uppercase, one with lowercase?
redbrick - REDBRICK...There may be a problem with Lumion filename case sensitivity.
Title: Re: Deleted materials
Post by: Zdenek Fajfrlik on November 28, 2012, 01:49:59 pm
Yes, I work in the same Revit, dae and lumion file. As you say, I changed the name of a material in Revit, because i have the same material applied on objects with different coordinates, so i had to rename them in Revit, red stone 1, red stone 2, etc, so then in Lumion i adjust UVW by objects. But i did it few times, also reloaded the revit file for modeling changes . But i can't understand why all my Lumion materials  disapeared!!!

ok, changing colour names IS the reason for the problems, sonce THE NAME is the identifier, as far, as i have learnt.
i workwith sketchup, an there were problems exactly withthis issue in theCILLADA EXPORTER inskp6, in skp8 all works well.
so maybe an update of your software could help . can you try another format to transfer to lumion?
regards stan
Title: Re: Deleted materials
Post by: Nicholin on November 28, 2012, 02:46:54 pm
Did you have any duplicate names, one with uppercase, one with lowercase?
redbrick - REDBRICK...There may be a problem with Lumion filename case sensitivity.


I have the same name with (1), (2), (3), etc
Title: Re: Deleted materials
Post by: Nicholin on November 28, 2012, 03:08:20 pm
ok, changing colour names IS the reason for the problems, sonce THE NAME is the identifier, as far, as i have learnt.
i workwith sketchup, an there were problems exactly withthis issue in theCILLADA EXPORTER inskp6, in skp8 all works well.
so maybe an update of your software could help . can you try another format to transfer to lumion?
regards stan

Yes, i had some problems before with 2011 and 2012 revit versions. Now I'm working with 2013 with the last collada exporter and it works so much better, even with large models, as I'm working now.
Curiously, I reaplied all materials, and there's an error with this numbered materials (red stone 1, 2, 3, etc.). I've changed the name few times and the erros remains, it seems that a name material got recorded in the DAE file

Thanks
Title: Re: Deleted materials
Post by: Morten on November 28, 2012, 03:57:49 pm
Hi Nicholin, stan is right.

When you import your model, Lumion makes a list of all material names from Revit.

If you then apply some Lumion materials to your Revit model and change the original material names in Revit before reloading the model, Lumion has no way of knowing which surfaces to re-apply the Lumion materials to.

In other words, never ever rename your materials in Revit if you need to reload the model.