Why are Spotlights not casting shadows?

Article Details



Poster: Morten
Article ID: 1
Posted: Thu 28 Jan 2016
Approved: Yes

QUESTION
Why are Spotlights not casting shadows?

ANSWER
Shadows from Spotlights are not displayed all the time for performance reasons. If you render an image or a video the shadows will appear again.

This sometimes makes the lighting brighter in Build Mode or in Photo or Movie Previews, but not with much less lighting, when rendered.  The shadows accurately clip (stop) the light from passing through surfaces like walls and floors.

Please also make sure that the Editor Quality is set to 2, 3 or 4 star quality (F2, F3, F4 keys). Otherwise you will not see any Spotlight shadows.

To preview shadows from Spotlights in Build mode, do one of the following:
  • Hold down (F8) or select the spotlights in Build mode to temporarily turn on real-time shadows.

To preview shadows from Spotlights in Movie/Photo mode, do one of the following:
  • Hold down (F8).


  • Apply a Global Illumination effect (New effect -> World tab -> Global Illumination), and click on Preview spotlight GI and shadows in the effect panel. If you want to view the shadows in Build mode while seeing the Movie/Photo effects, click on the Build with effects button in the top left corner.



If the shadow settings of the Spotlights are set to 'Accuracy' (via Edit Properties), the preview options above may have a significant impact on performance. There's more information about the performance impact of Spotlights in this article.


See Our Video Tutorial:
Tips And Tricks: Preview Spotlight Shadows Optimized For Accuracy [F8]

Press [F8] to quickly preview shadows for all spotlights shadows set to optimized for accuracy in the scene.



SA Knowledge Base
© 2011 - 2017 SMFHacks.com