This forum is now closed.
Please join us at the new Lumion Community forum.
Lumion Community
Use your email address and password from the old forum to log in if your account was created before Feb 20 2020.
Otherwise, you will need to create a new Lumion Account at the new forum.

Author Topic: [Awaiting reply] right&middle mouse button navigation stop working in Lumion 10  (Read 1021 times)

hugo_dai

    Reputation: 0
November 06, 2019, 08:39:41 pm
We recently upgraded the Lumion to 10 in our office and the right mouse button and wheel navigation stop working after the upgrade.

We tested this on two desktops and both have the same issue. Everything was working well before this upgrade. Even if we downgrade back to 9.5 the issue still occurs. It seems that the new version also affected the old one.

We have checked that the Setting Toggle Tablet Input is off and we don't have a tablet connected.

It makes the navigation process incredibly difficult. Please help us fix this problem!

Re: right&middle mouse button navigation stop working in Lumion 10
« Reply #1 on: November 06, 2019, 08:47:39 pm »
November 06, 2019, 08:47:39 pm
Hi Hugo, I'm sorry to hear that.

Just to keep you in the loop, it's not just you who are affected and we have received similar reports from about 10 other customers at the moment (and both Lumion 8, 9 and 10 seem to be affected).

Our developers are currently investigating the issue.

Their current theory is that it's caused by a recent Windows(?) or Google Chrome update as it happened from one day to the next and even affects older versions of Lumion.

Apologies for the problems this is causing you at the moment.

Incidentally, we just got a tip from another user.

He says that people have been able to 'resolve' the problem by reverting to a previous Windows Restore Point.

We're unable to confirm if it works as we haven't been able to replicate the error, so doing it would be at your own risk.

Here are the instructions if you would like to try it:

External Link: Recovery options in Windows 10

Alternatively, can you please try to quit Chrome while using Lumion and let us know if Lumion works as expected?
IMPORTANT: Please do not send private messages and emails to members of staff - unless we specifically ask you to send us sensitive information, for example License Keys.

hugo_dai

    Reputation: 0
November 06, 2019, 08:54:03 pm
Hi Morten! Thanks for the quick reply. I tried to quit Chrome while using Lumion and the issue still occurs.

November 06, 2019, 09:07:57 pm
Thank you.

For each of the following, run vcredist_x64.exe in:

Installation folder\Lumion 10.0\Redist2008
Installation folder\Lumion 10.0\Redist2010
Installation folder\Lumion 10.0\Redist2012
Installation folder\Lumion 10.0\Redist2015
Installation folder\Lumion 10.0\Redist2017

Respond to the application by either 'install' or 'repair'.

Then restart your PC.

Does this make any difference?
IMPORTANT: Please do not send private messages and emails to members of staff - unless we specifically ask you to send us sensitive information, for example License Keys.

hugo_dai

    Reputation: 0
November 06, 2019, 09:23:14 pm
I tried to install all the vcredist_x64. The 2015 and 2017 version cannot be installed. The snapshots are attached below. This makes no difference for the Lumion.

November 06, 2019, 09:31:40 pm
Many thanks.

At this stage, we 99% sure that it's something that's outside Lumion which is overriding the mouse input function that Lumion relies on.

We'll let you know if there are other steps to go through.

If you click on the 'Notify' button at the top/bottom of this Topic, you'll automatically receive an email alert the next time we reply.
IMPORTANT: Please do not send private messages and emails to members of staff - unless we specifically ask you to send us sensitive information, for example License Keys.

November 07, 2019, 11:46:53 am
Can you please follow these instructions and let us know if they resolve the problem?

1. Is Chrome installed on your PC? If so, please update it to the very latest version and restart Chrome when you're done.

If Lumion is launched after that, does the issue persist?

If it does, does restarting the computer and then starting Lumion fix the issue?

External Link: How to update Chrome

2. If the issue still persists, does updating Windows to the latest version and restarting the PC fix the issue?

Knowledge Base: How do you install the latest system software required to run Lumion?

3. If windows is already fully updated, does rolling windows back to a previous Windows Restore Point (before November 4) resolve the issue?

External Link: Recovery options in Windows 10
IMPORTANT: Please do not send private messages and emails to members of staff - unless we specifically ask you to send us sensitive information, for example License Keys.

November 07, 2019, 04:29:16 pm
4. Please type 'chrome://version/' in the address bar in Chrome and attach a screenshot like this:

IMPORTANT: Please do not send private messages and emails to members of staff - unless we specifically ask you to send us sensitive information, for example License Keys.

November 07, 2019, 08:01:39 pm
5. Does it help if you right-click on 'Lumion.exe' in the Lumion installation folder and select 'Run as administrator'?

Or even better, try to log in with an Administrator account if that's available to you:

External Link: How to change a Windows 10 user account type
IMPORTANT: Please do not send private messages and emails to members of staff - unless we specifically ask you to send us sensitive information, for example License Keys.

hugo_dai

    Reputation: 0
November 07, 2019, 08:42:10 pm
Hi! Thanks for the instructions. We don't have extra time to test each of these steps right now. Instead, we have set up Lumion 9.5 on a brand new PC and stopped Windows Update on that PC and everything is running smoothly as before.

We might try these instructions later. Also, please keep me updated if you find a solution. Thanks for your effort.

November 07, 2019, 08:46:29 pm
Thanks for letting us know. Glad to hear you have a workaround for the time being.

The problem is definitely linked to an update of a different application (or Windows).

Another user (Denizard) might have figured out the root cause of the problem: Are you using Microsoft Office on the PC that it occurred on?
IMPORTANT: Please do not send private messages and emails to members of staff - unless we specifically ask you to send us sensitive information, for example License Keys.

hugo_dai

    Reputation: 0
November 07, 2019, 09:01:20 pm
Yes. There are Microsoft Office on the PCs that have this problem.

November 07, 2019, 09:09:42 pm
Which version?
IMPORTANT: Please do not send private messages and emails to members of staff - unless we specifically ask you to send us sensitive information, for example License Keys.

hugo_dai

    Reputation: 0
November 07, 2019, 09:13:23 pm
Here is a snapshot

November 07, 2019, 09:14:55 pm
That's great. Many thanks. :)
IMPORTANT: Please do not send private messages and emails to members of staff - unless we specifically ask you to send us sensitive information, for example License Keys.