Author Topic: Objects not casting shadows?  (Read 4328 times)

Marvil

    Reputation: 1
Objects not casting shadows?
« on: December 09, 2010, 12:16:53 am »
December 09, 2010, 12:16:53 am
I'm really enjoying your wonderful product:)
Just one thing...background trees/objects don't seem to cast shadows, unless I get closer to them. I checked the shadow range setting and it's maxed out. Am I overlooking something?

Objects not casting shadows?
« Reply #1 on: December 09, 2010, 09:35:43 am »
December 09, 2010, 09:35:43 am
When an object becomes a billboard the shadow is gone. When rendering a movie or photo there are no billboards so the shadow is correct.

Marvil

    Reputation: 1
Objects not casting shadows?
« Reply #2 on: December 09, 2010, 03:08:28 pm »
December 09, 2010, 03:08:28 pm
Well...actually, if you look at this movie I made with lumion, you can clearly see that the trees are not casting shadows http://digitart3d.com/blog Confused

Did I overlook something?

Objects not casting shadows?
« Reply #3 on: December 09, 2010, 03:16:42 pm »
December 09, 2010, 03:16:42 pm
Amazing video.

 

It looks like the trees are billboards. You are sure you rendered at 3 star quality? If so this is a bug where the trees are still billboards. I'll look into it.

Marvil

    Reputation: 1
Objects not casting shadows?
« Reply #4 on: December 09, 2010, 03:44:02 pm »
December 09, 2010, 03:44:02 pm
Thanks for the quick reply!

Yes, I rendered at the best quality (3 stars). Thanks for looking into it!

Also....if you look on my movie, right around :59 or 1:00, there is a flicker on the glass (top right corner of video).

I'm not complaining or anything...just thought maybe you'd want to take a look at that too.

Thanks again!

Objects not casting shadows?
« Reply #5 on: December 09, 2010, 03:58:44 pm »
December 09, 2010, 03:58:44 pm
Probably the flicker is what is behind you at that moment. I am currently working on giving a movie effect that lets you decide where the cubemap for the reflection for the clip is created to avoid these glitches.

Objects not casting shadows?
« Reply #6 on: December 09, 2010, 04:14:15 pm »
December 09, 2010, 04:14:15 pm
The tree LOD seems to be fine. But looking again at your video I think the current shadow range is just not far enough for you. I'll change this so you can set the shadow range much further.

Marvil

    Reputation: 1
Objects not casting shadows?
« Reply #7 on: December 09, 2010, 04:15:58 pm »
December 09, 2010, 04:15:58 pm
That would be great! I'll re-render and re-post when you have the fix ready.

Marvil

    Reputation: 1
Objects not casting shadows?
« Reply #8 on: December 16, 2010, 05:47:30 am »
December 16, 2010, 05:47:30 am
Iinstalled the beta update and set the shadow Range to max (2.0). However, it seems to make no difference.

To be sure, I re-tested in 1.0 and matched the camera distance to the beta update. The trees stopped casting shadows at the same camera position in both Lumion versions. Maybe I am overlooking something?

Objects not casting shadows?
« Reply #9 on: December 16, 2010, 09:25:33 am »
December 16, 2010, 09:25:33 am
In realtime shot or also in final shot?

Marvil

    Reputation: 1
Objects not casting shadows?
« Reply #10 on: December 16, 2010, 03:37:58 pm »
December 16, 2010, 03:37:58 pm
You are right! I rendered the final shot and the shadows and trees looked great! It looks so much better now. Nice job!

Now if only we can get the lightmaps working again in the beta, I think I can use it in production.