Author Topic: Error Rendering DrawIndexedPrimitive with windows  (Read 5316 times)

Square

    Reputation: 1
Error Rendering DrawIndexedPrimitive with windows
« on: June 14, 2013, 10:26:25 am »
June 14, 2013, 10:26:25 am
Hi, I've just purchased Lumion Pro 3.2 and I'm facing a bug at start up. A widget pops up with an error message : "ERROR RENDERING DrawIndexedPrimitive". My OS is Windows 7 and I have an AMD Radeon HD 7970, that should (I suppose :) ) handle your software.

I've tried to update my graphic card pilots and re-install the software, but the issue is still there. I can solve it for 0.5s by clicking on Ok, the software goes on, but the widget pops up again right after that.

Do you have any idea or clue that can help me to solve this? Thanks in advance.

Re: Error Rendering DrawIndexedPrimitive with windows
« Reply #1 on: June 14, 2013, 11:06:35 am »
June 14, 2013, 11:06:35 am
Are you by any chance running Windows under OSX Parallels?

If so please see this topic: ERROR RENDERING DrawIndexedPrimitive

Otherwise we'll keep searching for some options.   ;)

Re: Error Rendering DrawIndexedPrimitive with windows
« Reply #2 on: June 14, 2013, 12:07:08 pm »
June 14, 2013, 12:07:08 pm
I think you're right, Peter - some Mac Pro models ship with an AMD Radeon HD 7970, so it is possible that he's using Parallels instead of a proper Windows installation via Bootcamp.
IMPORTANT: Please do not send private messages and emails to members of staff - unless we specifically ask you to send us sensitive information, for example License Keys.

Square

    Reputation: 1
Re: Error Rendering DrawIndexedPrimitive with windows
« Reply #3 on: June 14, 2013, 02:34:02 pm »
June 14, 2013, 02:34:02 pm
I'm sorry but no. I'm running a windows 7 64 bit standard installation, not from a MacOSX device. I've already taken a look at this topic, while searching for some solution. It would have been easier I agree.

Do you need extra information?


Re: Error Rendering DrawIndexedPrimitive with windows
« Reply #4 on: June 14, 2013, 03:09:12 pm »
June 14, 2013, 03:09:12 pm
Thanks for clearing that up, Vincent.

Please click on Run DXDiag in the benchmark section and attach the resulting dxdiag.txt file to your next post (it may take up to 1 minute to create this file, once the folder window has opened).
IMPORTANT: Please do not send private messages and emails to members of staff - unless we specifically ask you to send us sensitive information, for example License Keys.

Square

    Reputation: 1
Re: Error Rendering DrawIndexedPrimitive with windows
« Reply #5 on: June 14, 2013, 03:58:50 pm »
June 14, 2013, 03:58:50 pm
Hello again,
Some fresh news. I've managed to go through the benchmark by clicking (intensively :) ) on Ok. Thanks to that, I've reached the section you've told me and ran DXDiag (I think it's the standard DXDiag, isn't it? Because I've also run the standard one before discovering this section if you need the results too.) I've also attached Visual Studio to your application with DirectX in Debug Version via DirectX Control Panel and obtained the output that I have also attached to this conversation.

Then, it's getting really odd, because when I started again Lumion, it was now working without any issue ! Only benchmark has this problem (I've tried to re-run the benchmark and it pops up the error again indeed).

I hope it will help you to fix this bug. Fortunately, for me, it's not a blocking bug anymore.
Thanks a lot for your quick help by the way.

Re: Error Rendering DrawIndexedPrimitive with windows
« Reply #6 on: June 16, 2013, 10:25:28 am »
June 16, 2013, 10:25:28 am
Hi vincent.picou

Thanks for dx_diag files and futher details.

I can't see anything that might indicate such a low level DirectX error from the dx diagnosis.

The fact that it is now only happening for the Benchmark may just indicate some slightly invalid install of those files, although the download manager and installer verify during the process and you did a re-install.

Have you previously run any other version of Lumion and what was it?

Can you please verify:
1. You could not get past the Benchmark test scene so were not otherwise running Lumion.

2.  the Catalyst drivers are the most recent for the 7970 being:
       Display Driver ver. 12.104
       OpenCL(tm) Driver ver. 10.0.1124.2
       Catalyst Control Center ver. 2013.0328.2217.38225

I have attached two zips for the benchmark files.  Can you please unzip and replace each of these in the install folders, and then try re-running the Benchmark.  You will need Administrative rights to copy-replace these files.
1.  Benchmark.cgr.zip to C:\Program Files\Lumion 3.2\ArchitectEdition\Classes\Benchmark
2.  Benchmark.ls3.zip to \Program Files\Lumion 3.2\ArchitectEdition\Home

One final test option please if above does not work:
Close Lumion and run the VC Redistribution files (for Microsoft .NET framework).  See vcredist_x64 in folder C:\Program Files\Lumion 3.2\Redist201.

Thanks.

Re: Error Rendering DrawIndexedPrimitive with windows
« Reply #7 on: June 18, 2013, 04:23:16 am »
June 18, 2013, 04:23:16 am
Just a further thought on this.

You may need to test the GPU, make sure its running OK.  You can do that with various report and stress tools:
1.  GPU-Z
2.  OCCT
3.  GPU Shark and stress test FurMark

Re: Error Rendering DrawIndexedPrimitive with windows
« Reply #8 on: June 18, 2013, 12:20:38 pm »
June 18, 2013, 12:20:38 pm
Hello again, vincent.picou - I installed the latest AMD driver and ran the benchmark on my AMD Radeon HD 5850, but didn't spot any errors.

Could you also try to install the very latest driver, i.e. Catalyst 13.4 (released on 29/05), and run the benchmark again please?

I'd really like to figure out what is causing this problem :)
IMPORTANT: Please do not send private messages and emails to members of staff - unless we specifically ask you to send us sensitive information, for example License Keys.

Square

    Reputation: 1
Re: Error Rendering DrawIndexedPrimitive with windows
« Reply #9 on: June 19, 2013, 03:03:30 pm »
June 19, 2013, 03:03:30 pm
Hello again,

I'm sorry but I've tried every clue you gave to me, none of them worked. I've got the latest version of AMD Pilot (29/05) and tried to overwrite install files. GPU-Z didn't tell anything was going wrong. Anyway, I think my graphic card has some chances to be fine because I'm working quite intensively with 3D rendering every day.

I know "remote debugging" is not convenient, so good luck. =)

Re: Error Rendering DrawIndexedPrimitive with windows
« Reply #10 on: June 20, 2013, 06:49:55 am »
June 20, 2013, 06:49:55 am
Hi Vincent

Hmmm, sad  :'(, no clues if all those things made no difference. 

So, just to confirm again (bear with me  :)), running the Benchmark is now other only thing that causes the problem, other than that Lumion works OK, at least for what you have used it for so far?

What is the AMD Pilot, is that the same as AMD Catalyst?

Square

    Reputation: 1
Re: Error Rendering DrawIndexedPrimitive with windows
« Reply #11 on: June 20, 2013, 09:28:50 am »
June 20, 2013, 09:28:50 am
I'm sorry that nothing worked too. The AMD pilot was this one, so I guess that's the same that you described above : http://support.amd.com/us/gpudownload/windows/Pages/radeonaiw_win8-64.aspx .

Yes, everything else works fine fortunately. I haven't tried every feature yet but the basic ones do work.

Thanks again for your help.  ;)

Re: Error Rendering DrawIndexedPrimitive with windows
« Reply #12 on: June 20, 2013, 11:05:26 am »
June 20, 2013, 11:05:26 am
Do you have 2 or more graphics cards running?

Are you running your Radeon in Crossfire (either with physical dual cards, or some sort of multiple card arrangement mode but currently as one physical card only)?

Just to make sure we are referring to the same drivers, can you please un-install the "Pilot", run Driver Sweeper to completely remove old ATI drivers and install the Catalyst Software Suite (and not the beta due to it still being beta) and re-try the Benchmark test.  you can always go back to a Windows restore point after this if needed.

Thanks.

Re: Error Rendering DrawIndexedPrimitive with windows
« Reply #13 on: June 20, 2013, 11:08:59 am »
June 20, 2013, 11:08:59 am
Hi Vincent, in addition to Peter's questions/advice, the developers tell me that this error is generated by SpeedTree, i.e. the software which renders trees and plants in Lumion.

Can you check if you get the same error message if you open Files -> Examples -> Artistic Effects Demo scene, and render some of the clips?

P.S. Please click on Account at the top of this page, and add your Lumion 3 key to your profile. Once you have done this, you will get access to the full forum for commercial Lumion users.
IMPORTANT: Please do not send private messages and emails to members of staff - unless we specifically ask you to send us sensitive information, for example License Keys.

Square

    Reputation: 1
Re: Error Rendering DrawIndexedPrimitive with windows
« Reply #14 on: July 16, 2013, 09:38:58 am »
July 16, 2013, 09:38:58 am
Hi again,

Sorry for the response delay, I've been on holidays recently. To answer your question in chronological order :
- No I don't have two graphic cards, only one.
- I will re-install my driver when I have some spare time at work and I'll tell you the result.
- Indeed, that seems to be due to SpeedTree. The error pops up when I add trees and the sample you told me to open triggers this error too.

PS : Thanks for the tip, I didn't find where was the commercial forum. Now it's ok ;).