Author Topic: [Resolved]: Lumion not running on dedicated video card.  (Read 18139 times)

eliris

    Reputation: 1
[Resolved]: Lumion not running on dedicated video card.
« on: July 15, 2014, 07:42:39 pm »
July 15, 2014, 07:42:39 pm
Greetings all,

I have installed the Lumion Benchmark today and I just discovered that it uses my integrated intel HD 4000 graphics card by default. I changed my nvidia settings so that it launches the program using the NVIDIA gtx 675m graphics card for the program but it still uses the intel HD, hopefully I could right click the .EXE and tell it to run the program using the dedicated Nvidia card, but at that time the application closes as the splash screen flashes and I cannot find it by doing "ALT + TAB" but I can find it in the process manager.

Excuse me for the long block of text and I hope we can troubleshoot this together.


Technical specifications:
CPU:Intel core i7 3610
GPU1:Intel HD 4000
GPU2:Nvidia gtx 675m 2GB GDDR5
RAM:12 GB

Re: Lumion not running on dedicated video card.
« Reply #1 on: July 16, 2014, 05:16:51 am »
July 16, 2014, 05:16:51 am
Hi

Just ignore the reference in the Benchmark to the Intel.  The Benchmark uses DirectX to report some information, and it sees the prime graphics card as Intel, which is still true  :)

Optimus technology switches when needed to the NVIDIA, so as you have Lumion set to run on the GTX card then it will do so.

You can add your Benchmark results here if you like, just do a screencapture.  Note the GTX675M has a reasonable Passmark.

eliris

    Reputation: 1
Re: Lumion not running on dedicated video card.
« Reply #2 on: July 16, 2014, 10:39:01 am »
July 16, 2014, 10:39:01 am
Thank you for the reply,
I downloaded the competition version of lumion but unfortunately, it did the same thing, the program launches with the intel HD and I can select scenes and examples (but the intel is too weak to display it correctly), but even if I set my Nvidia settings, it always runs using intel HD. However, if I right click and tell it to run using the dedicated Card, it shows the splash screen for some miliseconds then nothing shows up but it is still in the process list.

I just reinstalled the newest drivers for my Graphics Card but it still behaves the same.

Screenshot:

Re: Lumion not running on dedicated video card.
« Reply #3 on: July 16, 2014, 11:08:18 am »
July 16, 2014, 11:08:18 am
Hmmm, well that's the right settings for the NVIDIA card to work.

Only thing can think of at moment and a bit left field, are you running the laptop on power or battery?

eliris

    Reputation: 1
Re: Lumion not running on dedicated video card.
« Reply #4 on: July 16, 2014, 12:36:14 pm »
July 16, 2014, 12:36:14 pm
My laptop is plugged in and running on power, it uses the High performance profile.

When it uses intel HD, the process takes up to 1Gb of memory, but when launched with a dedicated card, the "ghost process" only uses around 15mb
DirectX version is DX11 (if that helps in any way)

Re: Lumion not running on dedicated video card.
« Reply #5 on: July 16, 2014, 12:51:03 pm »
July 16, 2014, 12:51:03 pm
That can only mean there is something not triggering the NVIDIA card to run, or the card has some issues and is not running correctly.

Can you please:
1.  Run the DirextX diagnosis:  Windows --> Run --DXDiag and post the text file results to this topic.

You can also run various report and stress tools:
2.  GPU-Z
3.  GPU Shark and stress test FurMark
4.  PassMark PC Performance tool.
5.  OCCT

OCCT is very in-depth.  See what the others report.  Some such as GPU-Z is only reporting, so if you can attach a copy as  screencapture, thanks.

eliris

    Reputation: 1
Re: Lumion not running on dedicated video card.
« Reply #6 on: July 16, 2014, 01:03:04 pm »
July 16, 2014, 01:03:04 pm
Here in the attachments are my two logs, one from GPU-Z and one from DxDiag.

Re: Lumion not running on dedicated video card.
« Reply #7 on: July 16, 2014, 02:08:55 pm »
July 16, 2014, 02:08:55 pm
Thanks for those.  Nothing in there to indicate anything. :(

Can you please do a screencapture (use its own little camera to capture) of the GPU-Z showing the Graphics Card tab details (refer my pic).

eliris

    Reputation: 1
Re: Lumion not running on dedicated video card.
« Reply #8 on: July 16, 2014, 02:20:36 pm »
July 16, 2014, 02:20:36 pm
Here goes the screen capture:


I wonder if any other laptop users or Nvidia gtx 6xxm users has encountered this issue or if it's a personal problem :\

Re: Lumion not running on dedicated video card.
« Reply #9 on: July 16, 2014, 02:40:39 pm »
July 16, 2014, 02:40:39 pm
It's a mystery for sure.

Screencap looks OK, GPU-Z is at minimum, seeing the GTX 675M.

I'm curious about why the NVIDIA Control Panel does not show (in left hand panel) Display items.  In your earlier pic, there is just 3D Settings and Video.  There should  be a Display group for changing resolution, rotating, multiple monitor etc, but there isn't.  Given you have just checked and updated the drivers, it's unusual to say the least.

Can you post the text file from the System Information (NVIDIA Control Panel, bottom left corner).  Thanks.

eliris

    Reputation: 1
Re: Lumion not running on dedicated video card.
« Reply #10 on: July 16, 2014, 03:19:40 pm »
July 16, 2014, 03:19:40 pm
Here we go:
http://pastebin.com/LVpS3c2F

Sorry for not sending as attachment, this website's coudflare thought of it as a threat.

eliris

    Reputation: 1
Re: Lumion not running on dedicated video card.
« Reply #11 on: July 16, 2014, 05:38:42 pm »
July 16, 2014, 05:38:42 pm
I want to try reinstalling lumion but I'm afraid I will lose my license like the other person in another thread.
I want to say I will try later but I was really looking forward to participating in this year's competition  :-[

Re: Lumion not running on dedicated video card.
« Reply #12 on: July 16, 2014, 05:45:34 pm »
July 16, 2014, 05:45:34 pm
I want to try reinstalling lumion but I'm afraid I will lose my license like the other person in another thread.

Hi eliris, you will not lose your license by uninstalling and reinstalling Lumion.

A license might get locked if your harddrive crashes before you quit Lumion, but we can easily unlock it remotely :)

That being said, none of this is any good as long as you aren't able to use the 675M graphics card.

Nvidia's Optimus technology is not something we can override via Lumion, so Optimus gets to decide when to use the Intel HD and Nvidia 675M graphics cards.

It works for other people with similar laptop PCs, so in your case I would recommend contacting Nvidia.

I ought to mention that we have previously contacted Nvidia in order to ask them to include an Optimus profile for Lumion.exe in the official Nvidia drivers, but apart from telling us that they had forwarded the request to the relevant team at Nvidia, they still don't seem to have made any progress :(
IMPORTANT: Please do not send private messages and emails to members of staff - unless we specifically ask you to send us sensitive information, for example License Keys.

eliris

    Reputation: 1
Re: Lumion not running on dedicated video card.
« Reply #13 on: July 16, 2014, 05:53:25 pm »
July 16, 2014, 05:53:25 pm
Thank you for the reply and your concern  :)
I will try with compatibility modes, moving drives and maybe downgrading my driver to the latest version I remember being stable since the new ones are known to have bugs.
Will report if I find any solution. :)

eliris

    Reputation: 1
Re: Lumion not running on dedicated video card.
« Reply #14 on: July 16, 2014, 06:43:20 pm »
July 16, 2014, 06:43:20 pm
Also, I probably forgot to mention that I can chose which card to use when I first launch it, but when I select my Nvidia, the splash screen shows and the process runs in the background but the application is not showing, and the process is locked at around 13.420 Kb